Topic: AlphaTrack Loses Sync on Logic 9.1.3


I just got a new AlphaTrack to use with Logic 9.1.3.  This is my first experience with AlphaTrack and I'm relatively new to Logic as well.  The problem I'm seeing is that AlphaTrack and Logic sometimes seem to get a little out of sync when changing tracks with the Track buttons. 

Here's what's happening.  With the AT in PAN mode, I click on track #1 in Logic's Arrange window with the mouse.  In the Arrange window, track #1 is selected, the controller bar (on the left hand side of the track row) is lit, indicating the AT is controlling track #1.  The AT display shows the name of track #1, and the fader controls the volume on track #1.  All is well. 

I click the right Track button on the AT, and everything shifts to track #2 as expected: track #2 is selected, the controller indicator moves to track #2, the fader on the AT controls track #2 volume, the AT display shows the name for track #2.  Again, all is well.

However, sometimes when I press and release one of the AT Track buttons, (say, the right button to go to track #3 in my example), I will see the control indicator in Logic's Arrange window move to track #3, and the AT display shows the name of track #3, but track #2 remains selected in Logic, and the fader controls track #2 volume. If I then press the right button again, all control jumps to track #4.

I've noticed that the control indicator in the Arrange window seems to move when you press a track button, and the selected track seems to change when you release the button.  So it's almost like Logic sometimes isn't seeing the button release (even though the AT itself does see the release because the track name display changes as expected.) 

This doesn't happen all the time, but it's often enough to be annoying.   It does NOT happen when changing tracks using the left encoder.  Is this a problem with Logic, AlphaTrack, my system, or operator error?  More importantly, can anything be done to fix it? (I've tried the Logic/Preferences/Control Surfaces/Rebuild Defaults command, which made no difference.)

Boring details:  Running Logic 9.1.3 (32 bit mode) on a recent Intel MacBook Pro with OS X 10.6.6 (32 bit mode).  Downloaded and installed the AlphaTrack driver (version 1.4.1) and the AlphaTrack Logic plugin (1.3) from the Frontier website.  The AT settings in Logic are set as recommended in the "Logic 8 and AT V1.1" document: Flip mode = off, Display mode = Value, Channel Strip View = Arrange, Track lock = unchecked.   

Thanks in advance for any help.


Re: AlphaTrack Loses Sync on Logic 9.1.3

I've occasionally seen this behaviour as well, but have never spotted any pattern to it.  As you say, using the left encoder always works fine, and as I mostly changes tracks this way it's not been such a problem for me.  Selecting a track with the mouse usually puts things back in sync for me.


Re: AlphaTrack Loses Sync on Logic 9.1.3

Hi ObtuseMoose,

I get this as well and if I remember correctly it is a timing issue.  Like Chris said using the encoder, changing the track once more, or selecting with the mouse should get it back in sync. It's still a bit annoying but it's not operator error and it's not your system.


Re: AlphaTrack Loses Sync on Logic 9.1.3

Thanks for the replies, Chris and CS. 

Yes, using the left encoder works while in pan mode, but of course, not so in other modes.   I've not worked with the AT enough yet to know if it will cramp my style or not.   Still, I hope it's on a list somewhere to be fixed eventually. 

Thanks again,