Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Topic: Problem with AT plug in param display update in Digital Performer 6.0

James Steele wrote:

Just wanted to pass this along.  I know DP 6.0 is a very new version and it has a few wrinkles to iron out.  One problem I have noticed is that if I use Alpha Track to adjust a parameter on an inserted plug-in on a track in DP, the knob on the plug's GUI will turn as I turn the encoder on the AT, however the numeric value and the bar graph that appears on AT's display while adjusting the parameter does not move or update.

This seems to happen with all plugs.... UAD for example as well as MOTU's own factory plugs.

Can you verify this and also is this a MOTU fix or something that needs to be dealt with on your end?  Thank you!

CS:Hi James,

Thanks for posting. We just got our copy of DP6 as well and are still checking it out. Yes, I do see this behavior as well so there are obviously changes to their interface. Hopefully they are done in a way that we can respond to. Let us know if you see any other oddities along the way.

CS

James Steele wrote:

There's one OTHER oddity.  Remember the alternate version of the DP specific plug-in that you guys made when I asked about it (thank you buy the way), that mapped the rewind button on AT, to behave line the rewind button in DP (3 on numeric keypad) rather than reverse shuttle?  That used to work fine in DP 5.13-- even when DP was the background application.  Now, in DP6, it still works, but if you send DP back and bring another app forward, that Rewind isn't recognized.

CS:Added to the list to check.

Thanks,

CS

James Steele wrote:

Hi there... just to give you some more information that might be useful:

After much anguish (your typical pulling of hair and gnashing of teeth) I gave up on the combo of Digital Performer 6.01 + PPC + Leopard.  This combination creates issues with a number of VI's from Native Instruments and I got sick of waiting for a fix.

So... tonight after spending a day on this, I downgraded my dual G5 2.3 Mac back to Tiger (10.4.11).  All my previous broken Native Instruments VIs are working again... and lo and behold the problem with the little bar graph not updating on the AlphaTrack's display while adjusting a parameter with the rotary encoder is GGGGONE.

FURTHERMORE the jump to rewind keystroke is when DP is not frontmost app is fixed too.  Ugh....

So this definitely looks like a Leopard issue and if it's not happening on Intel machines, it's definitely another PPC/Leopard bugaboo with DP 6.01.

CS:Thanks for posting this James. I had not tried DP6 with Tiger so would have never found this. You Da Man!!!

CS

James Steele wrote:

Man... I am pulling my hair out.  I *was* committed to Leopard until the suffering with the combo of PPC/Leopard/DP6 got to be too much for me.

FYI, I've now uncovered an issue where it used to be that if you edited a parameter on a plug-in in DP, the plug-in window would automatically open.  I can do it right now on my machine when using DP 5.13, however it doesn't work in DP 6.01.   Another user I know using PPC/DP 6.01 on Tiger confirms this as well.

HOWEVER, this plug-in opening trick is working just fine for yet another user who is using Intel with Leopard 10.5.5.   Go freakin' figure.  I posted this on the Frontier board and there's some more here at the board that I run:

http://www.motunation.com/forum/viewtop … mp;t=31855

Re: Problem with AT plug in param display update in Digital Performer 6.0

Dear Mr. Scrutinizer:

Any chance I could get the modified plug-in that maps the AT "rewind" button to "return to start" with DP 6.02 under 10.4.11?  Thanks!

PS: When I downloaded the DP plug tonight, no read me file was included. Just an FYI.

Last edited by HCMarkus (2009-12-02 07:30:09)

Re: Problem with AT plug in param display update in Digital Performer 6.0

Hi HCMarkus,

If you press and hold(on your AlphaTrack) shift and then the rewind button does DP return to start?

CS