Topic: Midi issues

I get an issue when I try to use the Alphatrack with Reaper. I've already have had issues with AT with Pro Tools.
Any ways the issue says
"The Following Midi Inputs could not be opened: Alphatrack"
"The following Midi Outputs could not be opened: Alphatrack"

It's weird because when it gives me this notice it still functions. I can select tracks and they move up and down on the screen. and vice versa when I move them on the screen the fader moves up and down. But every time I do something like open a menu that message pops up again.

I also have Midi issues when I try to use it in pro tools 7.4 since I can't use the AT in Pro Tools 8.0 for some reason.
Got any ideas?
I thought there's pleanty of midi channels? I tried it as HUI and The fader instantly went down to the bottom.

How much would it have to do with the fact that I am using the Digi002R as the interface? I read all over that you can use Digi gear with Reaper and that your AT works fine with Pro Tools.
My computer is a HP Pavillion a6234x with Intel VIIV processor and it was down-graded from Vista to XP. Could I be missing a driver when I down-graded? I am also up-to-date with service pack 3.
anything else I should look for?

Re: Midi issues

I'm happy to see that the admin can'tt even answer this question. Maybe it's proof that they're stuff doesn't work that well. If you get the unit just return it. Look at all these issues they have with this thing.
Craigslist here I come! This thing is garbage!

Last edited by damionhill (2009-08-19 15:25:35)

Re: Midi issues

Hi Damionhill,

Sorry you're experiencing some troubles with your AlphaTrack and my apologies for the delay in response...

For use with ProTools 8 it appears that you have to make sure that you 'run as administrator' for it to work properly.  This may have been the reason you weren't able to use the AlphaTrack in PT8 and this solved the problem for many customers.

What kind of midi problems were you experiencing in PT7?  Since you have an 002 and PT7 you may have had to add dummy midi tracks in your projects to be able to use another control surface. It's explained further here: … rfaces.pdf

If you plug in your AlphaTrack does the AlphaTrack manager pop up on the screen?  Since you went from Vista to XP maybe unplugging the AlphaTrack and re-installing the latest drivers from our site would be a good idea:

As for your reaper problem, you might want to contact them and see what they have to say about that.  Did you make sure you were in 'Native' mode and in the Options\Preferences window click on the ‘Control Surfaces’ tab and select “Add” to access
the “Control Surface Settings” panel and then set the mode to “AlphaTrack” and the MIDI Input and output to AlphaTrack as well?

Re: Midi issues

First off... I will try the dummy tracks. But I doubt it will work. I will let you know the exact error I get.

As for reaper. yeah i set it up properly just as you explained. It gave me the error that I listed above. I read online how you setup the Tranzport thingy.

I have reinstalled the latest drivers to see if that worked and nothing seemed to change. I swear this thing has become such a nightmare.

I'll load Pro tools and let you know the errors I get.

Re: Midi issues

wow this has been a while...
OK so I still haven't used a dummy midi track. Is this normal for other control surfaces? I highly doutb most people would sacrifice the ability to switch between their surface and their keyboard controler.  I keep hearing this is a issue with all the DAWS. I find this funny because in most cases this is supposed to work. Why are their so many problems? Why is it so fussy?

As for the midi issues. Yes I have set them up multiple times trying out different solutions. Non have worked. It must be a configuration issue in windows. But Midi issues in both Reaper and Pro Tools. and some what the same issues. So this tells me that your alphatrack takes over the midi instead of being something seperate. How do things like the digi command8 for pro tools uses up the midi I/O or that the Mackie control takes away all use of midi functions until you're done using it?

I've been fighting the idea of selling this thing on craigslist or ebay. It's a waste of cash in opinion. I've never had issues with anything before until this. I'm going to try installing this thing one more time and If it doesn't work I'm going to write to your company and tell them to get on board with all the other manufactures and sell this pc of crap. I'm going to buy a mac and switch to Euphonix soon any how.

I dont believe you when you say that it's DAW. Because i've followed your instructions to  T and nothing helps.

Re: Midi issues

Hi damionhill,

In ProTools 8 you should be able to run as administrator and it should work. 

In ProTools 7 you mentioned that the fader goes to the bottom.  Does anything appear on the AlphaTrack LCD at this time?

You also mention that you have an 002, since (in ProTools) controllers view your project as chunks of 8 tracks you need to create 8 dummy midi tracks (as your first 8 tracks) as a buffer to allow both controllers access every track. This is not an issue in PT 8 because this problem was fixed by DigiDesign it's also not an issue in other DAW's because this is unique to HUI protocol but the dummy tracks should take care of that.

Also, if you're using a Command 8 you won't be able to use any other control surfaces in ProTools.

There's more information about this on the top link of a previous post.  Let me know if you get this working.