Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Topic: Frontier PCI WDM Interface Driver and MIDI error

rdaltry wrote:

When Frontier PCI WDM Interface Device is enabled, Mixer Device for MIDI audio output is forced to Dakota S 1:2 and cannot be changed from that setting. Please verify (WinXP) by using Control Panel -> Sounds and Audio Devices -> Audio Tab -> MIDI Music Playback - > Default Device. The integrated audio on my device is SoundMAX, so I set mine to SoundMAX WDM MIDI. Click on the Volume button for MIDI Music Playback and you will see that the Mixer Device is set to Dakota S 1:2. Select Options -> Properties and change the Mixer device to SoundMAX Digital Audio and press OK to save the change. The Volume control for SoundMAX Digital Audio is displayed. Close the Volume control window and click on the Volume button for MIDI Music Playback again. The Mixer Device is reset back to Dakota S 1:2.
     The only way to regain control of MIDI Music Playback is to open Device Manager -> Sound, Video and Game Controllers, and Disable Frontier PCI WDM Interface. With it disabled, the Mixer Device for MIDI Music Playback can be set and saved as desired. The Entry in Device Manager for Dakota PCI Audio Card can stay enabled, it does not appear to be connected to the problem.
     This is verified with the Dakota Control Panel -> System Tab -> MIDI Mode set to Disabled(PC full shut down and Power up) or 2x2(PC full shut down and power up again).
     Fix this bug in the Frontier PCI WDM Interface Driver please, or let me know where I've gone wrong. As it stands, this audio card cannot Sound Playback and MIDI Music Playback at the same time.

Regards,
Rdaltry

CS:Hello rdaltry,

The symptom you are describing may actually be buried in Windows code rather than the Dakota driver side. Win XP changed how many of the Sound and Audio control panel functions work from earlier versions. The Volume setting for instance, has been completely disabled for any add-on sound cards. However, in most cases these settings will have no affect on how the Dakota (or any other sound card) work with your actual DAW software. They may affect WMP though. But can you tell us what recording software you are using? Perhaps we can give a bit more detail.

CS

rdaltry wrote:

I use Sawstudio + Midiworkshop from RML labs for recording and WMP to play many file types. The first problem I'm trying to work through is with WMP. It is playing all files (even MIDI files), but even though I can see the MIDI files play on the progress bar, I can't hear the output. That's what lead me to Control Panel -> Sounds and Audio Devices -> Audio Tab -> MIDI Music Playback - > Default Device -> Volume button.
     I did notice in the Dakota Control Panel -> Clock/Device Status Tab -> Digital Output Status, that Device S 1:2 was linked to Opt A. So I removed that link. The result was that when Frontier PCI WDM Interface Device is enabled, Mixer Device for MIDI audio output is forced to Dakota A 1:2 and cannot be changed from that setting.
     I tried the checkbox to Disable S/PDIF in WDM on the Dakota Control Panel System tab. Rebooted the PC, but still the Mixer Device for MIDI audio output is locked to Dakota A 1:2.
     I tried Sound and Audio Devices Properties -> Hardware -> Frontier PCI WDM Interface  - > Properties - > Properties Tab -> Mixer devices -> Frontier PCI -> Properties, and selected 'Do not use Mixer features on this device' button. It appears that is in someway hardlinked to the same setting on the SoundMAX integrated digital audio device in that, any change made for the  Frontier device, forces the same change for the SoundMAX device.
     This problem is completely eliminated, and I can again hear the output of WMP when playing MIDI files if I open Device Manager -> Sound, Video and Game Controllers, and Disable Frontier PCI WDM Interface.
     If I then re-enable Device Manager -> Sound, Video and Game Controllers -> Frontier PCI WDM Interface, I can hear WMP play MIDI files and actually make use of Dakota. Upon reboot though, all the settings return to thier problem state. This leads me to believe this is fixable without having to wrestle with Device Manager after every power on.

RD


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Re: Frontier PCI WDM Interface Driver and MIDI error

I also use Frontier PCI WDM Interface Device and face the same problem that you face but didn't know whats its solution. Now I have got the solution by reading this post. thank you very much for this.


diet
weight loss

Last edited by Fitnessbuff1975 (2010-11-08 21:30:31)