Topic: Alphatrack/Logic bug

The problem I'm having happens randomly in while working in logic. Alphatrack is putting logic in record mode (very buggy) and this message pops up:

"Logic Pro has detected a possible conflict between one or more third party MIDI or audio drivers"

I have installed the latest Alphatrack driver and plug-in from the website.

What could be the problem?

Re: Alphatrack/Logic bug

Hello duncanmusic,

While I can't say for sure what might be causing this, it is not normal behavior. Here is a list of things you can try. Any one of them might solve the problem but you should try them in this order.

1. Confirm that you have only 1 copy of the AlphaTrack.bundle file on your computer, and it is located inside the Logic/Show Package Contents/Contents/MIDI Device Plug-ins folder.
2. Repair Permissions on the your entire computer.
3. Select Logic/Preferences/Control Surfaces/Rebuild Defaults.
4. Logic Preferences/Midi/Reset All MIDI Ports
5. Go to Logic/Preferences/Control Surfaces/Setup. Highlight the AlphaTrack icon and delete it. Then close and relaunch Logic.

If none of these seem to help then please tell us more about your system and any other MIDI devices you may have installed.


Re: Alphatrack/Logic bug

I tried all those steps and unfortunately the problem continues to persist.

Here are some of my specs and hardware:

Mac OSX 10.5.6
2x 3 GHZ Quad Core Intel Xeon
16GB Ram

MTP AV midi timepiece
connected to that are:

encore slidemate midi controller
Behringer B control Nano BCN 44
Kurzweil SP 88 Masterkeyboard

Re: Alphatrack/Logic bug

Does the message only appear when the AlphaTrack is connected? Do you have the latest drivers installed for you other devices?


Re: Alphatrack/Logic bug

Yes, I do have the latest drives installed. And the message only appears with Alphatrack. And for some reason puts me in record mode (sometimes cutting in and out of the mode).

Re: Alphatrack/Logic bug

When you installed the new plug -in  did you be sure to delete the existing AlphaTrack.bundle that originally shipped with Logic. The Apple version is very buggy and if somehow they were both on your computer it might cause all sorts of bad things to occur.


Re: Alphatrack/Logic bug


we still have problems with the alphatrack. I followed your instructions exactly. I deleted the bundle and everything else and reinstalled alphatrack.

Logic still starts to play by itself for 1 click, switches the cycle area, .... weird.

Anything else we can do?

The alphatrack Icon is a Keyboard and not the alphatrack picture.

Re: Alphatrack/Logic bug

The keyboard icon is ok.

Lets check 2 things.

First, do the AlphaTrack calibration (Shift+Stop+F4) to make sure all of its sensors are aligned in case it is picking up noise from something. Also, if you notice that any external things happen at the same time such as a cell phone sitting next to the AT ringing, that's important.

Next, try removing the MIDI Timepiece to see it the problem stops. If it does then reconnect it without any of the other devices. If it is still working then add each remaining device back 1 at a time until the problem reappears. This way maybe we can at least figure out where the conflict is if there really is one.


Re: Alphatrack/Logic bug

Hello, I'm having a similar problem with Logic 8 on my Mac OS x 10.5.6

The fader and other functions seem to be working fine but it randomly goes into Solo mode or Record mode.  I have followed the above advice and it hasn't helped.  Please let me know if there is anything else you can suggest.


P.S.  I am also running the Tranzport (which seems to work fine...) maybe there is a conflict?

UPDATE:  I tried connecting the device to a different USB port and it seemed to solve the problem.  I was originally connect to a HUB, then I moved it directly plugged into the computer USB port.   It could be just a fluke but wanted to give you an update nevertheless.

Last edited by MarcelloK10 (2009-03-07 04:47:34)

Re: Alphatrack/Logic bug

Thanks for the update Marcello.

Duncanmusic, is switching USB ports also something that you can try?


Re: Alphatrack/Logic bug

Thanks Marcello!

That did the trick. It was the hub. Why did I not think of that ...?
Anyway, thanks very much guys!