Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Topic: Logic 8 Track Select Issue

iceritchie wrote:

I had some issues after installing my AT (Mac 10.5.3) with Logic 8.0.2. I initially kept losing the Pan control and anything on the right control knob, this seemed to clear after i calibrated the unit. However since then i cant select through the tracks / strips using either the right hand knob in Pan mode or the Track buttons. No matter what i do i cant get it to work (tried rebuilding defaults, deleting controller in set up, reinstalling plug in (1.1) and reinstalling the 1.3.0 driver but no luck. I have only had it a few hours and am already disillusioned. Tried it quickly in Reason 4 and everything seems to work fine.

CS:Hello iceritchie,

Your track select problem may be due to the project setup rather than the AlphaTrack itself. Since it works ok with Reason we can safely assume the AT is working ok. You already mentioned that you tried rebuilding defaults and deleting the controller icon in setup, both good trys, but lets look at a few other things.

First, it is important to know that AlphaTrack will only scroll through tracks/busses that appear in the Arrange view. so make sure all of the strips that you want to access are also shown there.

Next, go to the Controller Setup panel and highlight the AT icon. Look down the parameter list on the left for 'Channel Strip View Mode'. Normally this should be set to 'Arrange' but try the others just in case.

Also try Logic/Prefs/MIDI/Reset All MIDI Drivers

Try testing with a new project to see if there might be some other project setting involved.

And don't forget to Repair Permissions on your Mac since you just added/updated things. This is a good thing to do periodically regardless.

The AT should work quite solidly with Logic once its happy. I suspect that something small is tripping it up at the moment.

CS

iceritchie wrote:

Tried all this but still no luck. If i manually change track to something other than track 1 on the screen with the mouse the AT will always move to track 1 when i try to cycle through tracks on the AT.

CS:

iceritchie wrote:

Tried tons of stuff. Reinstalling the drivers etc, re-calibrating, rebuilding defaults, trial and error on various setting such as listen to mmc. Still no joy. Everything else seems to be good other than the track select buttons / knob. I guess the next action is to box up and return. These buttons were ok initially when the pan was acting up, but since a calibration pan is OK but no track select.

iceritchie wrote:

This is now solved. I went into the preferences folder in my personal places area, i.e. in my case my folder area is in the user/library/preferences folder not the HDD root/library/preferences area. I then found multiple back ups of my logic pro preferences file ('com.apple.logic.pro.cs') I deleted them all. I also deleted the 'Alphatrack Settings' file in the preferences folder. Restarted everything and now working a treat.

I must add Frontiers Tech support were excellent and a major factor in me not abandoning the device earlier. They were in regular contact and offered constructive and progressive advice, while specifically listening to my exact issue carefully.

CS:Thanks for taking the time to post your solution Iceritchie. This is good information for everyone and certainly one that I'll make a note of.

Thanks for sticking with us. We hadn't run into this before so I apologize for not having the correct answer on the first try.

Enjoy,

CS