Yes - the modes are a bit hazy in the AlphaTrack documentation. to say the least (and I'm a real manual-hound)...

I finally found my Boss FS-5U pedal and it immediatly worked as it should (momentary was the key). God forbid that I ever need to implement any other kind of foot control!

Hi there, looked around the forums for a solution but did't see anything so here goes...

I had my footswitch punch-in/punch-out funtions working just fine with Alphatrack in Logic 8 using a Boss FS-5U momentary footswitch.

The control surface functions were all working normally as well after my upgrade to Logic 9 (and an reinstall/upgarde of Alphatrack Logic drivers/plugin).

However I have seemed to have misplaced my Boss FS-5U momentary footswitch and tried using a standard 1/4" latching footswitch from one of my Soldano amps, and it sent the the punch-in functions on the Alphatrack into a complete tailspin - literally continously punching-in & out like I was having an epileptic fit with my foot on the pedal. Same results with 3-other latching 1/4" footswitches (Fender, Randall, generic).

I tried everything I could think of including powering up the Alphatrack to recognize the footswitch, deleting Logic control surface prefs, re-installing Alphatrack, deleting/re-adding footswitch assignments in Logic, etc..

So is it Alphatrack under Logic 9? or the fact that I'm not using a momentary footswitch? I'm stumped... a complete night of recording guitar tracks wasted last night, because I couldn't get this figured out.