Yes, seems to have helped. I have launched Logic twice since following your instructions. Tranzport was present and behaved optimally both times.

Thanks!

Charles

An update to my previous post:

While your solution

(snip)
Go to Logic/Preferences/Control Surfaces/Setup and delete the TranzPort icon entirely. Quit Logic and relaunch it. This should force Logic to remount the Tranzport from scratch.
(end snip)

did provide a solution to my problem,
I have to repeat it EVERY TIME I try to use Tranzport with Logic 8.

I do not consider this to be an ideal solution. Do you?

Your final suggestion seems have brought Tranzport back online and back to life:

(snip)
Go to Logic/Preferences/Control Surfaces/Setup and delete the TranzPort icon entirely. Quit Logic and relaunch it. This should force Logic to remount the Tranzport from scratch.
(end snip)

Thanks for your prompt attention and for providing a workable solution I'll rely on from now on if I have further trouble.

—Charles

More Logic Studio/Tranzport problems:
MacPro Dual Core Xenon 2.66 / OS10.5.6 / Tranzport Manager 1.42

Error message on opening Logic:
Device “TranzPort” is assigned to MIDI Port “TranzPort” which is not present.
Please ensure that all MIDI interfaces are connected and switched on. If this is the case, please check the MIDI port setting of device “TranzPort”. If this is correct, click “Reset All MIDI Drivers” in Preferences > MIDI > General.

I complete all instructions above, and get the same error message every time.