Topic: Logic Pro 9.

Just a simple question:
Can I install the Alpha Track plugin into Logic 9?

Re: Logic Pro 9.

Hi Eric,

The AlphaTrack was natively supported in Logic 8 so there should already be a AlphaTrack plug-in in Logic. I expect all you should have to do is install the AlphaTrack drivers and Logic should recognize it.  We don't have a copy of Logic 9 here to test it but it shouldn't be any different from Logic 8 in recognizing controllers.

CS


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Re: Logic Pro 9.

I don't think so!
It seems that only your Tranzport is natively supported:

http://documentation.apple.com/en/logic … essupport/

And I have everything installed already. Just wondering if I should insert the plug-in into the Logic package?

BTW. I love your AlphaTrack. It's one of the best purchases I've made.
It was really handy on Logic 8.

Last edited by EricBradley (2009-07-27 17:01:10)

Re: Logic Pro 9.

There seems to be a problem with L9 and the Alphatrack.

Even with the plugin installed, the Alphatrack is not working properly. It is recognised in the Control Surface dialogue, but is totally non functional. No track indications on the LCD, no fader operation (they stick at null) and no track switching, etc. If you change back to L8, everything is fine again. I have taken a quick look at all the settings, and they seem OK...  this is with L8 and L9 on an  iMac with OSX 10.5.7, by the way.

Andy

Re: Logic Pro 9.

OK.. after installing it, you then need to DELETE it in the control surface dialogue (at least on my system). Then, with no control surface installed, select "ADD" and then choose Alphatrack.  Then it works.

Strange, but at least it solved the problem.

Andy

Re: Logic Pro 9.

I finally installed the plug-in into Logic 9.
Everything seems to work as expected but now there are enhanced features like the control surface colored marker working in the mixer.
Nice!

Re: Logic Pro 9.

I had the same problem - just installed Logic 9 and the Alphatrack didn't want to know. I followed 66d35's suggestion of deleting and then adding, but still nothing.

Here's what I did to solve the issue: in Applications I right clicked on both Logic 8 and Logic 9 and then clicked on 'Show Package Contents', then on 'Contents' and then on 'MIDI Device Plug-ins'. In Logic 8 I could see the 'AlphaTrack.bundle' but it was missing in Logic 9, so I copied it across from L8 to L9. As soon as I re-launched Logic 9, the Alphatrack sprang into life.

Hope this works for anyone else who's having problems.

Re: Logic Pro 9.

To markhs,
You sir are a genius. That worked for me 100%
Thanks so much!


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Re: Logic Pro 9.

markhs wrote:

Here's what I did to solve the issue: in Applications I right clicked on both Logic 8 and Logic 9 and then clicked on 'Show Package Contents', then on 'Contents' and then on 'MIDI Device Plug-ins'. In Logic 8 I could see the 'AlphaTrack.bundle' but it was missing in Logic 9, so I copied it across from L8 to L9. As soon as I re-launched Logic 9, the Alphatrack sprang into life.

Hope this works for anyone else who's having problems.

I just downloaded the plugin fron frontier design and used that one inside of L9.