Topic: Logic 8 - Don't see Alphatrack Icon


I'm trying to install my Alphatrack on my Mac for Logic 8. I followed the instructions in the Logic guide, but when I open Logic, I get the keyboard icon, not an Alphatrack icon. I've rebuilt the DB, reset my MIDI inputs, deleted the control surface, restarted logic, tried to replace the AlphaTrack.bundle file multiple times, rebuilt permissions - to no avail.

Will my Alphatrack still work as expected?


Re: Logic 8 - Don't see Alphatrack Icon

It seems to be working as expected based on the Logic user guide.

Is there a way to reprogram / assign what the touchstrip does? For example, I'd really like the two finger swipe to horizontally zoom in/out, but not sure how I can assign this.


Re: Logic 8 - Don't see Alphatrack Icon

Hi Charlemagne,

That AlphaTrack generic midi icon is ok and doesn't necessarily mean there's anything wrong.  There was actually a problem with the icon that we used and it shows as a generic midi controller.  As long as your AlphaTrack is functioning normally then it's ok.

If you Launch Logic and go to Logic/Preferences/KeyCommands and then click on the 'Various Windows' drop down list there are some zoom  commands "Zoom Horizontal Out" (and in) "Zoom Vertical Out" (and in).  As well as some other recall and save zoom commands.  If you click on one and click on the "learn new assignment" button on the right you can then map these commands to either F1-F4 or you can try the scroll strip although it won't be able to detect direction. If you try it you'll see what I mean. The right most side and left most side of the touch strip act as buttons and I found it worked well mapping one side to 'zoom in' and the other side to 'zoom out'. Keep in mind this may mean that you can't navigate through your markers since that's what the ends of the touch strip were originally mapped to.

You can also zoom in and out by using shift+F1, shift+F2, shift+F3 and shift+F4 to zoom in and out both vertically and horizontally.

If you mess up you can always go to Logic/Preferences/Control Surfaces and then go to rebuild defaults.

Learn more about user assignable buttons on the last page of the following document: … T_v1.1.pdf