Topic: Shift+transport functions not working as described in Logic 8

ChrisByrd wrote:

I've just bought an Alphatrack to use with Logic 8 - I've not delved to deeply so far but everything seems to be working fine (and I'm very pleased with the device), except for the shifted transport functions.  All the other shift function seems to work.

shift+play sometimes does nothing, other times the playhead jumps back to a few ticks after the last play location before pausing.

shift+rewind sometimes does nothing, other times the playhead jumps back to the last play location before carrying on rewinding, or the playhead just jiggles about on the spot.

shift+stop does nothing.

I'm running the latest version of Leopard, Logic and the Alphatrack driver,etc., and have tried re-calibrating the AT and rebuilding the defaults.

P.S.  I just tried the AT in Cubase 4 on the same Mac and the shift+transport functions worked as described in the manual, so it looks like the AT is OK.

CS: Hello Chris,

When you updated the AlphaTrack driver, did you also update the Logic Plug-In for it to v1.1? This is very important to do, and has to be done separately, as the default plug-in that ships with Logic is incomplete. The Rebuild Defaults command should reset all of the controller assignments back to the corrects settings.

Also, if you did install the updated plug-in by creating a new MIDI Device Plug-Ins folder in your Library folder then you should delete that and replace the original file within the Logic application itself.

ChrisByrd wrote:

I had a look in the controller assignments in Logic and noticed that for shift mode there were duplicate entries for the rewind and play controls - the second set of entries having the same parameters as for the unshifted controls.  I deleted the extra entries and shift+rewind and shift+play are now working properly.

Not sure how this could have happened (I'm fairly new to Logic, as well as the AlphaTrack), but at least it's working now :)