Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Topic: different digital performer problem

i also got a new imac, running X.5.6, and just installed the TranzportUB_DP_1_05 plugin. since then, dp constantly gives me a spinning beachball and recurring "connection failed" message and i cannot get any work done. in my log files i see this type of entry:

4/4/09 9:29:44 PM [0x0-0x28028].com.motu.DigitalPerformer[358] File '/Users/jerry/Desktop/Work/Tranz/DP_UBPlugin/Plugin/../../../MasDevKit/CodeForDevelopers/BundleResources.cpp', Line 64: Assert( fBundleResourceMap != -1 ) failed

since there is no user account "jerry" on my machine. i suspect this is a faulty line in the plugin code.

Re: different digital performer problem

Hello Stringtheory,

Ya,  we're aware of the "Jerry"  line in the code. It was left in there accidentally by one of the plug-in programmers but I am confident that it isn't the root of the problem you are having. It only shows up in the error message.

Here are a few things to check.

1. Verify that the TranzPort Manager is set to "Native" mode before launching DP.

2. If you can use TranzPort (set to iTunes mode in the TranzPort Manager) to remotely control iTunes than you know the basic TranzPort drivers, and the unit itself are working just fine. If this is the case than we can focus solely on the DP configuration.

3. Verify that your do have v1.0.5 of the DP plug-in and it is located in the correct folder (HD/Library/Audio/Plug-Ins/MOTU Control Surface). You should see a few other controller plug-ins in there as well that get installed with DP. The TranzPortUB.bundle Plug-In should be 88kb in size and have an icon that looks like either a 2-pinned audio jumper, or a cube.

4. If you right-click (or CTRL-Click) on the plug-in itself you should see a menu appear. Select "Show Package Contents", then open "Contents". There you should see 3 items; a file called info.plist, a folder called MacOS, and another file called Pkginfo. Let us know if you don't see all 3 of these.

If you move the TranzPortUB.bundle back to the desktop from its current location are you then able to launch DP successfully?

Check these things out and let us know what you find. I'm sure we can get you sorted out.

CS


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Re: different digital performer problem

1. verified

2. can use with itunes

3. verified all, including size. however, icon is generic document icon (page with folded corner)

4. all 3 items are there.

if i remove the bundle to the desktop, i still have the same problem with dp. and i don't get the error message. now i suspect something has gone wrong with dp or a plugin...anyway, with the bundle installed, i get hundreds and hundreds of lines in my log such as: 4/11/09 1:52:28 PM [0x0-0x2f02f].com.motu.DigitalPerformer[386] File '/Users/jerry/Desktop/Work/Tranz/DP_UBPlugin/Plugin/../../../MasDevKit/CodeForDevelopers/BundleResources.cpp', Line 64: Assert( fBundleResourceMap != -1 ) failed

i mean, hundreds and hundreds of lines like that...

Re: different digital performer problem

ok, problem solved, nothing to do with the tranzport...very glad of that because i love the device! turns out it was a dp "clipping" that referenced a text file on a volume that no longer exists since i migrated to new external drives...thanks for your time & help.