Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Topic: Live 7.0.10 issue - Alphatrack is cool, but the computer!

CarlLofgren wrote:

Hey - last time I was here I was with Cubase 4 - that relationship is slowly coming to an end in favor of Ableton Live. I got the Alphatrack running fine with C4 - thanks to you guys - but again I am finding myself into trouble, and this time with Live.

After a couple of unsuccessful tries - I uninstalled the driver (using the control panel) and installed it again. Then I followed the instructions for the settings in Live. Last time it worked quite well - now I can do all the stuff with AT in Live like I could in C4. Brilliant. Just to one little detail - the computer is slightly weird. The mouse pointer sometimes freezes when I'm moving it - and especially when I am moving a fader with the mouse - it moves a few pixels, then freezes and I no longer can move the fader with the mouse (I can still move it with the AT - but not with the mouse. In fact the mouse pointer disappears. By double clicking a couple of times seems to do the trick and "release" the mouse from the pointer.

Well... to put it short. I like the AT - but I also like my mouse. Would it be possible for them to co-exist, in a peaceful manner?

/Carl

Windows XP Pro SP2, 2GB RAM, Intel Dual Core, Novation Nocturn, Akai MPC 2500, GenoQs Octopus, Virus TI.

CS:Hi Carl,

Well, we're glad to here that things are mostly working as they should for you. The AT and mouse should be fine together. I haven't heard of this issue before and I'm not sure how the AT could cause the mouse to momentarily freeze like that, but here are a few questions that might get us pointed in the right direction. Live's MIDI control I/O is handled completely separately from its mouse/keyboard I/O so this is a bit peculiar.

First, if you remove the AT do you ever experience the mouse freezing? Try with it just de-configured in Live, and then completely disconnected. Do you experience this problem at any other time? Is the symptom really related to the AT being online?

Does your Novation Nocturn exhibit any similar behavior? One thing to keep in mind that isn't necessarily related to this issue is that, even though Live can distinguish different controllers by name in its setup, it can only separate their commands by MIDI channel. So if the AT and Nocturn are both on channel 1 (AT is fixed to ch.1 in Live) it can confuse their input/output data. Be sure to move the Nocturn to another channel if it is also configured in Live. Also, check your MIDI Mapping panel for any custom settings that might be interfering.

Also, do you have the latest Live and AT updates?

Any other clues that you notice?
CS

CarlLofgren wrote:

Hi there. Problem seems to be solved - so I just post my findings here, so maybe that will help out others.

I still have no idea of what caused all this, but what I did was this. First I uninstalled the drivers - completely deleting all traces of drivers on the hard drive and in the registry. Then I re-arranged some of the connections on my usb-hub, I connected one more hub - but this one with a power adapter. I figured that maybe the solution was at the fact that the AT didn't get enough power.

That - and a fresh reinstallation of the driver did the trick. I had to experiment a couple of times to get it right though - but, yeah... now it _seems_ to work.