Topic: MIDI stuttering when recording with the 1.07 plugin

Hello,

I am using Cubase 4.5.2 with Alphatrack and an RME Multiface II interface.

I was really happy to see the new plugin released and the latency problems being corrected.

However, with the latest releases of the plugins 1.06 and 1.07 I found out that a big problem was introduced.

Now when I record midi in Cubase, randomly, Cubase stutters for 2-3 seconds(playing the same chunk of audio) and while this is happening the notes I record are recorded on the top of each other.

This was not happening when I was using the previous versions of the Alphatrack Cubase plugin(I mean the 1.05 and earlier) and I have not changed anything on my system at all.

The only thing I can suspect is the new timecode display that was introduced with the Alphatrack new plugin. As far as I can see now Cubase is constantly sending midi data to the Alphatrack in order to have the timecode synchronized and maybe this is causing the midi stuttering problems.

I have been painstakingly trying all the different midi ports in Cubase( Windows Midi, the defaults for Alphatrack, Direct Music, Direct Music Emulated) with no success whatsoever.

The problem keeps happening at random times (that's why it is very difficult to reproduce) and it was NOT happening with the plugins prior to the "Timecode"versions. It doesn't happen when I disconnect Alphatrack all together from my system as well.

This is really frustrating, I don't know if something messed up with the Cubase midi machine(or windows?) but right now I am in the middle of nowhere and I am not sure on what to do to cure the problem.

I searched Cubase forum and users who are experiencing the same problem are also having Alphatrack.

Can you give any help please? This is really serious.

Re: MIDI stuttering when recording with the 1.07 plugin

Hello Domenico,

I'm not sure what you mean by the "Timecode" reference in the new AlphaTrack plug-in. We didn't add, or make any changes with regards to timecode display or synchronization.  The update should only affect how the Solo, Mute, Rec Arm function update for the AlphaTrack itself.

If you remove AT from your Device Setup does this symptom still occur? If so then it must be caused by something else.

Tell us about this timecode thing and we'll see if we can find any link to our plug-in work.

CS


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Re: MIDI stuttering when recording with the 1.07 plugin

Central Scrutinizer wrote:

Hello Domenico,

I'm not sure what you mean by the "Timecode" reference in the new AlphaTrack plug-in. We didn't add, or make any changes with regards to timecode display or synchronization.  The update should only affect how the Solo, Mute, Rec Arm function update for the AlphaTrack itself.

If you remove AT from your Device Setup does this symptom still occur? If so then it must be caused by something else.

Tell us about this timecode thing and we'll see if we can find any link to our plug-in work.

CS

Hello,

By timecode I mean the feature that was added in Alphatrack even before the latency fix problem, and I mean the Bars, Beats and Ticks that are now displayed on the Alphatrack LCD screen. They were not there before, so, when a Cubase project was playing, it was not transmitting midi data constantly to Alpha Track. Now it is sending messages all the time. And since that happened my problem also began.

Up to now, when I unplug Alpha Track from my system the problem does not occur.

Regards,

Domenico

Re: MIDI stuttering when recording with the 1.07 plugin

Ah, ok. None of that was changed at all in the recent updates. Actually that Bar/Beat display is just reading data that Cubase is already generating. We aren't really asking it to do any extra work.

But if disconnecting the AT seems to cure your problem then it sounds like maybe there is some other setting that is causing excess MIDI load with the AlphaTrack in your case.

You might try resetting all MIDI drivers from the MIDI Port Setup. Also, if you have timestamping enabled at the bottom of that page it might bog things down. Timestamping adds a lot of MIDI overhead. Check that AlphaTrack In is NOT enabled as an "All Inputs" device too.

Let us know if any of this helps or not.

CS


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Re: MIDI stuttering when recording with the 1.07 plugin

Central Scrutinizer wrote:

Ah, ok. None of that was changed at all in the recent updates. Actually that Bar/Beat display is just reading data that Cubase is already generating. We aren't really asking it to do any extra work.

But if disconnecting the AT seems to cure your problem then it sounds like maybe there is some other setting that is causing excess MIDI load with the AlphaTrack in your case.

You might try resetting all MIDI drivers from the MIDI Port Setup. Also, if you have timestamping enabled at the bottom of that page it might bog things down. Timestamping adds a lot of MIDI overhead. Check that AlphaTrack In is NOT enabled as an "All Inputs" device too.

Let us know if any of this helps or not.

CS


I am not quite sure, but I don't remember Alpha Track receiving so many Midi data before from Cubase.  The midi out light in Cubase used to send so many midi events only with my BCF2000 in the past.

Anyway, thank you for your suggestions.

Actually, before posting here I did some tests on my own and after no one of them succeeded only then I decided to post.

So here are the tests:

Before doing anything the configuration was as follows:

Multiface II ports : Direct Music IN/OUT

Alpha Track: Windows Midi

System Timestamp checked for Direct Music Only

I changed this configuration with this:

Multiface Midi: Direct Music

Alphatrack: Windows Midi

System Timestamp checked for Direct Music and Windows Midi

Then:

Multiface and Alphatrack on Windows Midi ports w/ Timestamp enabled.

Then:

Multiface: Direct Music (Emulated)

Alphatrack: Direct Music (Emulated)

Timestamp Checked.

Then:
Multiface: Direct Music Emulated

Alphatrack: Midi In: Direct Music Emulated 
                   Midi Out: Windows Midi

System Timestamp enabled to both Direct Music and Windows Midi.


I have tried many different combinations as you can see :)

Some of them worked for a while, then exhibited the same problem.

Do you have any combination in mind that is likely to work?

I have made sure that Alphatrack is NOT shown in the All Inputs. Especially when I found out that Alphatrack can transmit MIDI NOTES as well! (Was mistakenly as the default midi device for Chainer standalone host). In fact, even by touching the fader  I could play notes!

Please let me know if the info I provided you with above is of any help and if you have something to suggest. Also do not hesitate to ask me for more info if necessary.

Regards,

Domenico

Re: MIDI stuttering when recording with the 1.07 plugin

Hi Domenico,

I am very curious about the MIDI Port assignments that you mention. You have tried the AlphaTrack's MIDI ports to be either 'Windows MIDI' , or 'Direct Music'.

On the "MIDI Port Setup' panel it should set it to Windows MIDI with Timestamping turned off, like your original settings. When you then check the AlphaTrack's own MIDI In/Out port assignments they should both be set to itself (AlphaTrack).

Also, check any MIDI tracks that you have in your project and make sure none of them accidentally have the AlphaTrack selected as an input or output port.

CS


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Re: MIDI stuttering when recording with the 1.07 plugin

Central Scrutinizer wrote:

Hi Domenico,

I am very curious about the MIDI Port assignments that you mention. You have tried the AlphaTrack's MIDI ports to be either 'Windows MIDI' , or 'Direct Music'.

On the "MIDI Port Setup' panel it should set it to Windows MIDI with Timestamping turned off, like your original settings. When you then check the AlphaTrack's own MIDI In/Out port assignments they should both be set to itself (AlphaTrack).

Also, check any MIDI tracks that you have in your project and make sure none of them accidentally have the AlphaTrack selected as an input or output port.

CS

OK, these were my initial settings. I have checked again and again that the Alphatrack is not assigned as an input in any midi track and have excluded it from the "All Midi Inputs".

So Windows Midi Ports and Timestamp deactivated was the first setup and I still have problems.

Re: MIDI stuttering when recording with the 1.07 plugin

I have been doing some tests with Cubase 4 and an AT that maybe you can try too. Here are my observations.

With the "Don't You" demo project running and all automation turned off. (You can use one of your own projects)

1. If the AlphaTrack is in PAN mode so that the Bar:Beat info is displayed I see a normal outgoing MIDI pulse rate of about 2 or 3 per second. (Watching the Cubase transport bar midi output meter).

2. If I touch (but do not move) the fader, or any encoder, or change modes so that the Bar:Beat info is not displayed, the midi output stops completely.

3. If I have automation on the selected track and turn Read on, then that will add midi activity relative to how much automation there is.

Can you tell me what you see if you repeat this same test?

CS


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Re: MIDI stuttering when recording with the 1.07 plugin

Central Scrutinizer wrote:

I have been doing some tests with Cubase 4 and an AT that maybe you can try too. Here are my observations.

With the "Don't You" demo project running and all automation turned off. (You can use one of your own projects)

1. If the AlphaTrack is in PAN mode so that the Bar:Beat info is displayed I see a normal outgoing MIDI pulse rate of about 2 or 3 per second. (Watching the Cubase transport bar midi output meter).

2. If I touch (but do not move) the fader, or any encoder, or change modes so that the Bar:Beat info is not displayed, the midi output stops completely.

3. If I have automation on the selected track and turn Read on, then that will add midi activity relative to how much automation there is.

Can you tell me what you see if you repeat this same test?

CS

Hi,

I think we are in the good track of tracing the problem here.

I did the tests you suggested and I got the same behavior that you describe.

The thing is that before the new plugins the midi output meter was not sending info when recording midi. Like when you touch the fader or when you touch a knob. That's why I suspect that this continuous transmit of midi data has something to do with the conflict.

Re: MIDI stuttering when recording with the 1.07 plugin

When you say "recording midi", do you mean when recording automation from AlphaTrack, or do you mean notes from your MIDI keyboard, etc?

Cubase would have always shown controller MIDI traffic to/from the AlphaTrack regardless of what plug-in version. The traffic that you see when doing these tests is normal and definitely shouldn't be enough to cause problems.

If you have MIDI echo turned on for your keyboard or other midi devices then you may have a MIDI loop when recording which would cause huge amounts of unwanted traffic and potentially bog your computer down. Particularly if timestamping is also enabled.

CS


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Re: MIDI stuttering when recording with the 1.07 plugin

Central Scrutinizer wrote:

When you say "recording midi", do you mean when recording automation from AlphaTrack, or do you mean notes from your MIDI keyboard, etc?

Cubase would have always shown controller MIDI traffic to/from the AlphaTrack regardless of what plug-in version. The traffic that you see when doing these tests is normal and definitely shouldn't be enough to cause problems.

If you have MIDI echo turned on for your keyboard or other midi devices then you may have a MIDI loop when recording which would cause huge amounts of unwanted traffic and potentially bog your computer down. Particularly if timestamping is also enabled.

CS

I mean recording notes from my midi keyboard.

I know that I was always shown of the midi traffic this is totally normal. The thing that wasn't happening before was that the midi output was like when you are touching the fader when recording midi data! I mean when someone was recording midi or audio or anything there was no additional midi output activity from Cubase to Alphatrack! The only time when there was midi output activity from Cubase to Alphatrack was when you pressed a button on Cubase in order to show that action to Alphatrack as well. But after the latest plugins there is CONSTANT output activity from Cubase to Alphatrack when recording or playback and that's what I suspect is causing the computer to bog down. Too much amount of midi information? I think this is where the problem lies.

Re: MIDI stuttering when recording with the 1.07 plugin

Any ideas?

Re: MIDI stuttering when recording with the 1.07 plugin

Well, the amount of MIDI data it takes to drive the Bar:Beat readout should definitely not be enough to bog your system down. It is really only a small bit. But you can test that by selecting any mode other than PAN so that the info is not displayed to see if it has any effect. Cubase will only show that outgoing data if AT is displaying the location.

Also, if you revert back to an older Plug-In,  does this symptom disappear?

This sounds like a MIDI track or VSTi has maybe got the AlphaTrack selected as one of its MIDI ports accidentally.

You could also start with an empty project and see what happens when you add tracks to it.

CS


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Re: MIDI stuttering when recording with the 1.07 plugin

Central Scrutinizer wrote:

Well, the amount of MIDI data it takes to drive the Bar:Beat readout should definitely not be enough to bog your system down. It is really only a small bit. But you can test that by selecting any mode other than PAN so that the info is not displayed to see if it has any effect. Cubase will only show that outgoing data if AT is displaying the location.

Also, if you revert back to an older Plug-In,  does this symptom disappear?

This sounds like a MIDI track or VSTi has maybe got the AlphaTrack selected as one of its MIDI ports accidentally.

You could also start with an empty project and see what happens when you add tracks to it.

CS


What I describe is of course tested over and over again. What I mean is:

I have tested this with completely new empty projects with a very light VSTi loaded. It does not happen right away nor is it possible for a midi track to have Alpha Track assigned as a midi input since:

1. It does not exist in the midi inputs. I have disabled it.
2. It does not happen immediately. I have to record midi for half an hour or so to happen and sometimes it doesn't even happen.
3. When I disconnect Alphatrack the problem disappears.
4. Other Alpha Track users from other forums have reported this problem.

I know it's a bit hard to solve but I bought Alpha Track to use it (and have recommended it to a lot of colleagues and students) and I don't think that unplugging it from my PC is a solution.

Re: MIDI stuttering when recording with the 1.07 plugin

Hi Domenico,

I understand your frustration, and you shouldn't have to disconnect the AlphaTrack to work. I have not heard of other reports of this, or seen other treads on it so I have to work from what you tell me and try my best to reproduce it. I just haven't been able to yet.

A few important questions that I am not sure about yet are:

If you change modes on the AlphaTrack so that the Bar:Beat display is not showing, do you still see this symptom?

If you go back to an earlier AlphaTrack Cubase Plug-in does the problem go away?

When you mention that you have disabled the AlphaTrack as an Input, how did you do that? Disabling the "All Inputs" box on the MIDI Port settings only removes AlphaTrack from the default "All Inputs" setting. It is still possible to select it a specific MIDI device as an input to any MIDI track.  This is why I mentioned that caution.

You're item #2 is interesting new information. Is there anything different about when it does happen and when it doesn't? Same project or different?
Also, I know I mentioned this before, but be sure all timestamping is turned off. That adds a huge midi load that will build the farther into a sequence you go.

One more question, are you chasing any other external timecode?

CS


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Re: MIDI stuttering when recording with the 1.07 plugin

Central Scrutinizer wrote:

Hi Domenico,

I understand your frustration, and you shouldn't have to disconnect the AlphaTrack to work. I have not heard of other reports of this, or seen other treads on it so I have to work from what you tell me and try my best to reproduce it. I just haven't been able to yet.

A few important questions that I am not sure about yet are:

If you change modes on the AlphaTrack so that the Bar:Beat display is not showing, do you still see this symptom?

If you go back to an earlier AlphaTrack Cubase Plug-in does the problem go away?

When you mention that you have disabled the AlphaTrack as an Input, how did you do that? Disabling the "All Inputs" box on the MIDI Port settings only removes AlphaTrack from the default "All Inputs" setting. It is still possible to select it a specific MIDI device as an input to any MIDI track.  This is why I mentioned that caution.

You're item #2 is interesting new information. Is there anything different about when it does happen and when it doesn't? Same project or different?
Also, I know I mentioned this before, but be sure all timestamping is turned off. That adds a huge midi load that will build the farther into a sequence you go.

One more question, are you chasing any other external timecode?

CS


Hello,

I have been very busy on some projects right now, but unfortunately I am not recording midi at the time so I cannot test thoroughly.

However let me answer to some of your questions as they may help:

The stuttering happens in random time. They happen on completely different projects. Even on very heavy ones or very very light with just a midi track and Halion One loaded.

When I say I disabled Alphatrack as an Input I mean that I went to the Midi Port Setup in Cubase and unchecked Alpha Track from the "All Inputs" section and from "Visible". That way, Alphatrack is neither visible in All Inputs neither can be selected.
Do you have any other way in mind that I could try? I believe I am secure this way but if there is something else I could try please let me know.

As far as timestamp is concerned, I have Windows Midi Timestamp deactivated(AT uses Windows Midi ports), however, I cannot deactivate Direct Music Timestamp as this results in late recording of midi notes.

I am not chasing any external timecode. The only midi devices on my system are :

Multiface II Midi IN/OUT
Motif ES8 connected via Midi to my Multiface
Alphatrack
Nocturn
BCF2000(which I haven't used for some months now. Certainly not after I got Alphatrack :) )