Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Topic: Where's the Sonar Plug-in?!

abaraxadac wrote:

I am running Sonar 7 Producer on Vista, and after installing the Alphatrack patch from both the CD and the website, I cannot find the AlphaTrack.dll file the user's guide refers to anywhere.  It says it should be "inside the Program Files\Cakewalk\ Shared Surfaces folder where SONAR is installed on your computer." but I could not find it there after running the driver install that should have placed it.  I tried searching my computer for it, but searching for the AlphaTrack.dll file with the search function only turned up the user guide itself.
When I turn on Sonar, the AlphaTrack sends midi signals that my soft synth responds to(as high pitched notes), but after assigning it in the options/controller surfaces box in Sonar, it will not do anything it is supposed to.  I would really rather not try and re-map each function, since I have no experience with that, and I am assuming the AlphaTrack.dll file will plug-in the control functions for me anyway, but for some reason the driver install is not loading it where it should.
I have tried looking for it as a stand-alone download, but if it is here anywhere I am missing it.  Any thoughts?

Hello abaraxadac,

When you first ran the AlphaTrack installer, there is a page where you can check boxes to select specific application plug-ins to be added. These include Cubase, Nuendo, Audition, and Sonar. I would disconnect the AlphaTrack and rerun the installer, making sure to check the Sonar box when it is shown. This should but the .dll file in the correct location. Ifyou are mixing 32-bit Sonar with 64-bit Vista then let us know as there is a special method to do this.

Once the 'dll file is in the correct location then you should find "Frontier AlphaTrack" as an option in the first column of the Control Surface setup.

CS

Abaraxadac wrote:

I knew about the box to check, this particular install package makes it obvious, and I had done that.  I decided to try installing just the plug-in from the CD once I realized that you could uncheck the box next to the driver on the same page- this was after I had turned off my comp for the day and came back to it the next.  I do not know if restarting the computer or installing just the plug-in did the trick, but I found the file in the correct folder, while not running Sonar.  The instructions just say to restart Sonar, but maybe the comp needed it also.
In addition, when I opened up the "import ACT data" window from the options\controllers/surfaces page, it did not list the file at first.  I had to hit the drop down menu for file type, and change the selection to all file types to see it.
Then, when it still didn't work, I figured out that I needed to have my controller highlighted in blue by selecting it with the mouse in the options\controllers/surfaces page before I loaded the ACT data.
The controller promptly started working fine, and I realized that all my pitches were off from me messing with the thing while not having it configured properly.
Hope this helps the next guy..

Abe.

CS:Since Cakewalk added ACT to SONAR the Control Surface setup defaults to ACT as the Controller type. It is important that you click on this menu and change it to Frontier AlphaTrack (or TranzPort if that is what you have) as well as set the MIDI In /Out settings to itself as well. Glad to hear you're up and running.

CS