Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Topic: Using two midi controllers in Logic

tomc11 wrote:

Just added the AlphaTrack and it works great. However, as soon as I turn on my Midi Keyboard Controller (for synth control), I get the 'Missing Alpha Track' message. This continues until I turn the keyboard off. Is there some way to toggle between the two controllers without constantly receiving those messages.

CS:Hello Tomc11,

If you are turning the keyboard controller on after Logic is already running then you are probably just confusing it. Try turning it on and then hitting the 'Reset MIDI Ports' option in your Logic MIDI Prefs. Logic should be fine with both devices on together.

CS

tomc11 wrote:

The above really doesn't appear to work. When I go to the utility program 'Audio/Midi Setup' on OSX 10.4 the screen shows both the AlphaTrack and the Keyboard, I do a Rescan Midi then run the Test Setup. The keyboard sends out a note however the AlphaTrack issues nothing.
I'm trying to find some way of setting each item to a different midi port (1 and 2). This setup program doesn't appear to allow me to change the values of the port. They are both showing as port 1 for Midi Out. Right now the Alphatrack buttons issue sounds from whatever instrument is on the selected track (only if the keyboard is on).

CS: The settings in Audio/MIDI Setup shouldn't be a problem. I really suspect it is just confusion within Logic itself caused by changing or adding MIDI devices on the fly. Go to Logic/Preferences/Control Surfaces/Setup and highlight the icon for AlphaTrack. In the parameter list on the left be sure that the MIDI in and out ports for AlphaTrack are both set to itself. Or you can delete the AlphaTrack icon entirely and  then close and relaunch Logic. That will force Logic to reconstruct its internal profile for the AT.