Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Topic: How Do I Uninstall Alphatrack In Logic Pro?

adavis wrote:

Help,

After shutting off my midi interface by accident while logic was still running, my alphatrack stopped working correctly and I want to uninstall it. I ran the uninstall program  and also removed the alphatrack bundle from inside the midi folder in logic but I keep getting a warning that the alphatrack can't find the midiport it's assigned to. Before I uninstalled it I tried rebuilding defaults, resetting midiports and reinstalling the software but nothing works. The alphatrack responds when I change tracks with the mouse or raise the volume fader using the mouse but not when I move the controls on the unit itself.

Thanks for any help,

adavis

CS:Hello adavis,

your initial symptom sounds like Logic's profile for ALphaTrack got corrupted. The fix for that, as well as getting Logic to stop flagging the AlphaTrack when disconnected is the same.

Go to Logic/Preferences/Control Surfaces/Setup. Highlight the AlphaTrack icon there and delete it. Close Logic and relaunch it. NOw when you add AlphaTrack back in it will force Logic to reconstruct its profile for the device, including the MIDI port assignments which is what was probably messed up.

enjoy,

CS