Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Topic: XP no Tranzport Midi interface

Royce wrote:

Hi .
PC  - XP SP2
Installed latest Tranzport drivers (device manager shows 1.4.0.0)
There are no MIDI input or outs in MidiOx or Sonar

Windows Audio service is Started in the Administrative Tools\Services control panel.

Installed and rebooted several times.
Removed all other Midi devices.
Tried WDM properties
  tried to used audio /not use audio - Map and don't map
  Midi features turned on
  Mixer on/ off

Any thoughts?

Royce

CS: Hello Royce,

Does the TranzPort task bar icon show up when you connect the USB interface? And does it link to the TranzPort remote ok?

Can you elaborate on the "all other MIDI Devices"? More specifically, what devices do you currently have, AND previously had since the last XP install? It may be that you have maxed out the XP MIDI port list and need to clean some out. You can find details on that problem here.

CS

Royce wrote:

Hi CS
Does the TranzPort task bar icon show up when you connect the USB interface? Yes
And does it link to the TranzPort remote ok?        The binding? Yes

I have been using the TranzPort for some time and it has been working beautifully.

Devices... MidiSport 4x4 , BCR2000 - Midi Yoke - but all were happy before.

I have now removed my MidiSport & BCR2000

I had a look at the URL - regedit- and although there are multiple entries of the same driver the list only goes to Midi6

I deleted all of them anyway and uninstalled the tranzPort drivers and my M-Audio Delta 66.
Rebooted and XP found them both, but in regEdit  Midi to midi3 are all wdmaud.dll
MidiOx can't find a Midi interface.

Both TranzPort Drivers appear in Device manager

Thanks for the help
Royce

CS: Very strange. Normally if the unit is binding and the task bar menu is working then we know the drivers are loaded properly and the computer is seeing it just fine. At that point the 2 things that can then prevent its MIDI ports from showing up are the Windows Audio Service being disabled, or too many MIDI ports. Both of these seem to be ok on your system.

You could try connecting to a different USB port however I'm not sure that will help. Assuming not, I would try removing the drivers and resources following the steps as detailed on page 10 on the TranzPort User's Guide, and doing a clean install.

CS

Royce wrote:

Hi CS
I did a complete clean install and still no luck.
Looks like the many hours of a XP install unless you can think of anything else?

Thanks anyway

Royce

Delax wrote:

I have the excact same problem.

The Windows Audio service is started and the blue icon is visible and it works in ITunes.
It is just not visible any where in windows as a MIDI device and not in Cubase 4 either.

I got a Synchrosoft and an ILok and AMT8 8 MIDI port device from Emagic on USB too.

Could it be the AMT8 that is shadowing?  I also have an old SB Live for windows sound.

I'll try for some time and return it if I can't make it work.  Itunes tranzporting is not enough for me and life is too short for windows driver hell.

I find it a little strange that the driver says 1.4.0.0 when the installer is named 1.4.1?

Delax wrote:

Ok now I have solved the problem.

Tranzport is made to show up in devicemanager as two devices. TranzPort and TranzPort WDM Interface.

Somehow the WDM interface had a yellow exclamationmark wich it certainly shouldn't have after installing the 1.4.1 exe file. (windows could not restart by it self either)

I just thought it was windows seeing the same device twice.

Just update the drivers from the devicemanager->update driver on the unknown device(I updated the TranzPort too) and it will turn into the TransPort WDM Interface wich is the MIDI device.

It is the fact that windows finds two devices that is mistaken for a windows buggy "I have found a lot of brand new hardare" shit :)

The installation file TranzPort_Win_Setup_1.4.1.exe seems not to work in all situations.  I had to update the unknown device afterwords with the drivers from the exefile to make it work.

Royce wrote:

Thanks Delax.
I tried all of that before. I don't have the yellow question marks on any of the drivers.
I reinstalled all the Midi devices (BCR, BCF MidiSport 4x4) and everything is working except the Tranzport.
All the lights are on but no Tranzport midi device in the list.
I reinstalled the 1.0 version from the CD, but still no luck.

Royce wrote:

I finally tracked down the solution.
The Plug and Play enumerator was somehow uninstalled. I have no idea how.

From this web page
http://weblogs.asp.net/lkempe/archive/2 … 75765.aspx

   1. In services, check that WinAudio service is enabled, set to automatic, and running.
   2. In Device Manager, System Devices check that Plug and Play Software Device Enumerator is installed and running

If not , then you need to reinstall it:

   1. Copy machine.inf from %windir%\inf to your desktop
   2. Remove line ExcludeFromSelect=*
   3. Use Add new hardware wizard using the Have Disk option
   4. Select the machine.inf you saved on the desktop
   5. Install Plug and Play Software Device Enumerator

What a business. I though that the plug and play service was running but I missed this.
Thanks for all the effort guys.

Royce

CS:Wow, good find Royce. I have to admit, not being an expert in all of the deep, dark secrets of Windows myself, I never would have known that one. You get a gold star for the day!

CS