Topic: Alphatrack still no worky with Logic 9.1.1 in 64 bit w/new drivers

I've deleted the old drivers and installed the new "64 bit" drivers and booted Logic up in 32 bit mode first.  Alphatrack works fine there but not after I reboot logic in 64 bit. What is the "trick?"

Re: Alphatrack still no worky with Logic 9.1.1 in 64 bit w/new drivers

Hi daveyboy,

This may be because the driver installer checks which kernel you're using to determine which driver to install.  So it's important that you're using the kernel you plan on using when you do the driver install.

So boot using the 64-Bit kernel, make sure the AlphaTrack is unplugged.  Then install the latest (1.4) drivers and reboot (still in 64-Bit kernel) and see if the AlphaTrack manager icon pops up on your computer screen when you reboot.  Then click on it and see if it says "AlphaTrack Available" and that it says version 1.4 in there somewhere.

CS

Re: Alphatrack still no worky with Logic 9.1.1 in 64 bit w/new drivers

So I need to boot the mac up in 64 bit mode and install? How is that done? I can't run Logic in that mode as many of my other things won't work (UAD2 card for example). It sounds like the new driver might be a bust for the moment. Please correct me if I'm wrong.

Bottom line: does Alphatrack work with Logic 9.1.1 while Logic is running in 64 bit but the mac os is running in 32 bit?

Re: Alphatrack still no worky with Logic 9.1.1 in 64 bit w/new drivers

Hi daveyboy,

How exactly are you rebooting Logic in 64-Bit/32-Bit modes? Maybe I'm misunderstanding.

CS


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Re: Alphatrack still no worky with Logic 9.1.1 in 64 bit w/new drivers

Central Scrutinizer wrote:

Hi daveyboy,

How exactly are you rebooting Logic in 64-Bit/32-Bit modes? Maybe I'm misunderstanding.

CS

I go to the Logic app and "get info". There I make sure 32 bit mode box is u checked. I then boot up Logic in 64 bit mode. After the install of the new Alphatrack driver there is no change in Alphatrack. Ie,it still doesn't work. I just now learned how to boot the mac up in 64 bit kernel and reinstalled the new driver as you suggested but had to leave before I could test. Although, I know this won't work as I have to be running the mac in 32 bit kernel. I thnk the problem is that there is no "Logic specific" new driver out so it can't work no matter what untill you guys write a new Logic driver, correct? Assuming that's the case then nothing has changed for Logic users. Once again, someone correct me if I'm wrong or am missing something obvious.


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Re: Alphatrack still no worky with Logic 9.1.1 in 64 bit w/new drivers

Central Scrutinizer wrote:

Hi daveyboy,

This may be because the driver installer checks which kernel you're using to determine which driver to install.  So it's important that you're using the kernel you plan on using when you do the driver install.

So boot using the 64-Bit kernel, make sure the AlphaTrack is unplugged.  Then install the latest (1.4) drivers and reboot (still in 64-Bit kernel) and see if the AlphaTrack manager icon pops up on your computer screen when you reboot.  Then click on it and see if it says "AlphaTrack Available" and that it says version 1.4 in there somewhere.

CS

+1

I have also had no result getting the Alphatrack to work in Logic 9.1.1 64-bit mode . I have rebooted in the 64-bit kernel (http://macperformanceguide.com/SnowLeopard-64bit.html ---- great article helping me with that here)...

I made the mistake of forgetting to unplug the the Alphatrack the first time I installed the 1.4.0 update, but then rebooted in 64-bit kernel, uninstalled the Alphatrack in its entirety, rebooted, reinstalled the Alphatrack manager 1.4.0, rebooted, replugged in the Alphatrack, and still, no worky.

However, rebooting in 32-bit kernel and Logic 32 bit mode continues to work fantastically.

What are we missing?

Re: Alphatrack still no worky with Logic 9.1.1 in 64 bit w/new drivers

ok,

1. i have set my mac pro 2008 to boot into 64bit-> reboot
2. disconnect my alphatrak
3. start the new installer
4. removed all early alphatrak software (not the logic plugIn stuff) -> reboot
5.  installed the new alphatrack driver -> reboot
6. plucked in the alphatrack -> Alphatrack Menu was available and my alphatrack also was found here
7. switch logic also to start in 64bit mode
8. start logic
9. nothing = no alphatrack
10. opened the controller setup in logic and removed the alphatrack here
11. closed logic
12. started logic again
13. nothing = no alphatrack
14. opened the controller setup in logic
15. nothing = no alphatrack
16. closed logic
17. switched logic to start in 32bit mode (under 64 snow leopard)
18. opened logic again
19. alphatrack is here and works well ;-)
20. mh ?
21. closed logic
22. switched snow leopard to boot into 32Bit mode again
23. reboot
24. start logic again
25. alphatrack is here and works well ;-)
26. ????

finally, alphatrack don`t work under 64bit logic and 64bit snow leopard

Last edited by Coil (2010-10-09 09:54:07)

Re: Alphatrack still no worky with Logic 9.1.1 in 64 bit w/new drivers

I've done the exact same thing as stated above with no luck as well.

Re: Alphatrack still no worky with Logic 9.1.1 in 64 bit w/new drivers

This is not working with Logic 64-bit.

You shouldn't have to boot os x kernel into 64-bit.
We only want it to work in 64 bit with a 32-bit kernel!!!


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Re: Alphatrack still no worky with Logic 9.1.1 in 64 bit w/new drivers

EricBradley wrote:

This is not working with Logic 64-bit.

You shouldn't have to boot os x kernel into 64-bit.
We only want it to work in 64 bit with a 32-bit kernel!!!

no, we want to work in 64bit logic with a 64bit kernel !!!!

the new mac pros will start into 64bit kernel by default, so it doesn`t make sense not to support this feature.


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Re: Alphatrack still no worky with Logic 9.1.1 in 64 bit w/new drivers

Coil wrote:

no, we want to work in 64bit logic with a 64bit kernel !!!!

the new mac pros will start into 64bit kernel by default, so it doesn`t make sense not to support this feature.

Fair enough!
What I mean is that most people don't use the 64-bit kernel due to problems with hardware drivers.

It should of-course work with the 64-bit kernel but it should definitely not be required.


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Re: Alphatrack still no worky with Logic 9.1.1 in 64 bit w/new drivers

EricBradley wrote:

.
It should of-course work with the 64-bit kernel but it should definitely not be required.

ok ;-)

Re: Alphatrack still no worky with Logic 9.1.1 in 64 bit w/new drivers

as i have mentioned above i returned to 32bit snow leopard and 32bit logic.
everytime when i start logic now, it crashes !

i have removed the whole alphatrack driver stuff and i disconnect the alphatrack with the same result.

there is nothing other i have changed on my system !

god save SuperDuper! - so i have an actual system backup (just one step before i have installed that new alphatrack-driver-monsterthing) on my external hd.

next time i will wait what other users say, before i install anything from frontier design again on my system.

Last edited by Coil (2010-10-10 13:40:29)

Re: Alphatrack still no worky with Logic 9.1.1 in 64 bit w/new drivers

Just installed the new driver, and am finding the same as others.  It works fine in 32-bit mode (SL and Logic), but not with Logic in 64-bit mode. 

A new Logic plug-in is obviously required as well, but how long will this take to develop?  I love the Alphatrack but do want to use Logic in 64-bit mode.  Is it finally time to look for alternatives to the Alphatrack?

Re: Alphatrack still no worky with Logic 9.1.1 in 64 bit w/new drivers

For those using Logic64 an AlphaTrack/Logic plug-in (v1.3) is on its way.  Shouldn't be too long so check the AlphaTrack downloads page for a v1.3 AlphaTrack plug-in in the coming days.

CS


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Re: Alphatrack still no worky with Logic 9.1.1 in 64 bit w/new drivers

Central Scrutinizer wrote:

For those using Logic64 an AlphaTrack/Logic plug-in (v1.3) is on its way.  Shouldn't be too long so check the AlphaTrack downloads page for a v1.3 AlphaTrack plug-in in the coming days.

CS

Thanks.


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Re: Alphatrack still no worky with Logic 9.1.1 in 64 bit w/new drivers

ChrisByrd wrote:

A new Logic plug-in is obviously required as well,

it would have been Frontierdesign's job to give us this very information many days ago, instead of letting each of us waste hour after hour. I'm really getting upset about this (non) information policy.

Re: Alphatrack still no worky with Logic 9.1.1 in 64 bit w/new drivers

Hopefully a couple days means a couple days this time. :-)

Re: Alphatrack still no worky with Logic 9.1.1 in 64 bit w/new drivers

Been a few days now is there any word?  In order to beta test the driver you must have a 64bit plug-in to test it with right?  Small oversight I guess, just rambling now because I can't wait to get my alphatrack up and running again.  It's been hell without it!

Re: Alphatrack still no worky with Logic 9.1.1 in 64 bit w/new drivers

hm, any news please ?


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Re: Alphatrack still no worky with Logic 9.1.1 in 64 bit w/new drivers

An updated AlphaTrack/Logic plug-in (v1.3) is now available on our AlphaTrack's downloads page:

http://frontierdesign.com/Products/AlphaTrack/Downloads

Anyone using Logic in Logic's 64-Bit mode will need this plug-in (requires Logic 9.1.2).

CS


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Re: Alphatrack still no worky with Logic 9.1.1 in 64 bit w/new drivers

This is the control surface plug-in for Logic version 9.1.2 only.

so, logic 9.1.3 is out, anyone tried this ?


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Re: Alphatrack still no worky with Logic 9.1.1 in 64 bit w/new drivers

Coil wrote:

This is the control surface plug-in for Logic version 9.1.2 only.

so, logic 9.1.3 is out, anyone tried this ?

seems to work fine here!!!

Re: Alphatrack still no worky with Logic 9.1.1 in 64 bit w/new drivers

thanks a lot !

Re: Alphatrack still no worky with Logic 9.1.1 in 64 bit w/new drivers

I changed the description for the plug-in.  It should read 9.1.2 and later.

CS