Topic: Alphatrack screen does not light up

The first few times I used the Alphatrack (Mac G5, ProTools) it worked fine. Today the screen does not light up. I have it plugged into the USB port on the front of the computer. I tried moving it to a port on the rear of the computer but it still does not light up. The fader and controls seem to work fine but I cannot tell what the screen is displaying.

Is there a setting?
Does it need to be "reset".

Any help/ideas would be appreciated.

Last edited by grubay (2010-05-11 21:04:08)

Re: Alphatrack screen does not light up

Hi grubay,

In DP have you tried going to setup/control surface setup and make sure that the AlphaTrack are both configured properly? You may also want to try deleting the AlphaTrack from the list and then just readd it to see if it helps.  Also, make sure that you're still in 'Native' mode prior to launching DP.

Does the screen stay dark even when plugged in or does it look like the LCD backlight comes on when plugged in?  If the backlight never comes on then it's possibly a hardware issue.