Topic: AT and Novation Remote SL together in Logic 8?

taoyoyo wrote:

Hi there,

I've just purchased both these controllers for use with Logic 8 (running OSX 10.5.3 on a Mac Pro), they both seem to compliment each other nicely (AT great for fader-type stuff, SL good for quicker plug-in editing).

I'm having a slight issue where the AT boots the SL offline when Logic has loaded up and the only way I've found to get the SL back online is to hit the 'Reset All Midi Drivers' in the Midi Preferences window in Logic. This works fine but it's an extra step to get everything working that I'd like if possible to eliminate.

I wondered if anyone had any tips on how to get these two to play nicely with each other?

(I've also been thinking as a last resort it might be possible to program a button on either controller to send the 'Reset all Midi Drivers' message but on further investigation it doesn't look like this is an assignable key command).

Many thanks,


CS:Hi Alan, you should be able to sort this one out. There are a couple things you can try.
First, try deleting the AT icon from Logic's setup window entirely and then relaunching Logic. Also, highlight each device in the setup and make sure that the MIDI In/Out settings for each device is set to only themselves.
Do you have the latest driver updates for both devices? The latest AT Logic plug-in is v1.1. I don't know about the SL.


taoyoyo wrote:

Thanks for your reply CS.

I'm pretty sure I have the latest drivers for both units (downloaded from the websites).

Tried your first suggestion... it didn't help.

Had a look at the Midi In/Out settings (In SetUp/Control Surfaces/Preferences... AT is set for Alphatrack In/Out, the SL is set to Port 2 In/Out. Tried changing it to Port 3, it didn't make any difference, the SL (Automap Universal) gets booted offline as soon as the At is recognized by Logic (AT fader goes up, SL goes offline).

The only other part in the equation is an M-Audio Keystation 88es (the one without controllers) but I don't think that is involved.

CS:Logic 8 updated as well? This is a real brain teaser.


taoyoyo wrote:

Yup, Logic 8.02.

I just tried a little experiment... unplugged the AT and deleted it from the Control Surface setup. Then rebooted Logic with just only the SL plugged in... the SL went offline without the AT being connected.

So it looks like the problem is not linked with the AT afterall. Maybe something to do with Logic or the SL software.

Thanks so much for your help though CS... Gotta say I'm impressed with the AT so far too.


I deleted the SL from the Control Surface prefs and rebooted Logic... it actually works and doesn't go offline when not being there in Logic. Strange.

CS:Very strange. Sounds like maybe there's some kind of clash between Logic's own control surface protocol and the SL's AutoMapping code. Isn't there something in the AutoMap control panel that says whether or not it presents itself as a Mackie Control, or some other device, to the host application? I don't know their stuff that well but I vaguely remember something about that. If so try disabling or changing that setting. Just a thought.

taoyoyo wrote:

I've worked out what the issue was, except it isn't an issue, it's apparently how it's supposed to work...

When Logic boots up the SL defaults to Template 39, which is the Logic template. At this time the Mixing part of Logic cannot be automapped, so it boots Automap offline but you can adjust the mixing parameters (if you so choose, I bought the Alphatrack to do handle this part of the equation) via the template settings.

Template 38 is the Automap template, which loads up plug-in settings on the SL as you initiate them in Logic... and this was the mode that I assumed the SL would boot up into (and it would have done if I was using say Live rather than Logic).

So when removed from the Logic Control Surfaces setup the SL defaults to Template 38 rather than 39 as it is not properly connected with Logic. When the SL is connected the only option is to either reset midi drivers or (the slightly more elegant) change template.

Mystery solved. More User Error (or Confusion) than anything else.

Thanks for sticking in there and offering help even after it was clear that the Alphatrack wasn't the problem... muchly appreciated CS! :)