Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Topic: Logic 8.0.2 Issue

seantock wrote:

I've just updated Logic to 8.02. At the same time, I updated the OS to 10.5.3, and the AlphaTrack bundle for Logic to version 1.1.
The alphatrack will no longer control the master and output buss faders. Although the alphatrack display says the master, for instance, is selected, it will not operate the master fader. Instead, it will move the last track fader that was selected. I have removed and reinstalled the alphatrack driver, and the alphatrack bundle for Logic and tried "rebuilding defaults".

Any ideas how I can remedy this problem?

CS:The keyboard icon is normal in OS 10.5.x. That's not a problem. The buss problem is not a genaric issue. It sure sounds like a setting or project configuration thing. I'll try to find a way to repro it at the office this week. Or if one of you wants to send a project file that demonstrated this to support@frontierdesign.com. Mention that its for CS.

Have any of you tried this on a new project created from scatch?

CS

rogerpaolo wrote:

Ok I found a solution.

Apparantly the AT only controls channel strips that are represented by tracks in the arrangement. So if you add a track there for every aux, output and master strip you can control them. of course this is not the most desirable situation, I sent 2 files to CS, one with and one without the auxes, master and output in the arrange window, I hope he will come up with a better solution.

Roger out.

CS:Ok Roger, I see what you mean. And yes, the AT can only control tracks (or busses) that are present in the Arrange view. (by the way, for anyone who isn't already familiar with this, you can easily add a bus to the Arrange view by CTRL or right-clicking it in the Mixer and selecting "Creat/Select Arrange Track".

This has been the case right along so I'm not certain if there is a feasible way to change it or not in our plug-in. I'll put this on the wishlist for the next time we revisit that code.

CS

daveduffus wrote:

Just want to post some clarification and suggestions to Logic users who may be confused by this thread...

Firstly, The AlphaTrack can select and control ANY mixer channel (that includes AUDIO, AUDIO INSTRUMENT, MIDI, AUX, BUSS, OUT, MASTER)...

BUT...

the channel must appear in your ARRANGE window.

Adding a channel to your arrange window is very simple.
Let's say you want to control an AUX channel from the AlphaTrack...
1. Open the MIXER window
2. Right Click (or Control Click) on the AUX channel and select "Create/Select Arrange Track"
Beautiful!

Now, for those who can't cope with the fact that you now have those ugly AUX channels cluttering up your ARRANGE window...
1. Select the AUX channel in the MIXER
2. Click in the greyed-out space above the Pan control in the Channel Strip and select an unused group (eg "Group 1").
3. Name it... - maybe "AUX"
4. Tick/Check "Hide Track" (uncheck all other boxes)
5. You can now easily assign the same "Hide Group" to all other relevant Channel Strips by clicking in their mixer channel's greyed-out box and selecting the same group.
6. At the top of the ARRANGE window click the "H" (Hide Button) so that it glows green (not orange).
7. "H" buttons will now appear for each track in the ARRANGE window.
8. Click the "H" button for one of those ugly AUX tracks. Now all AUX tracks assigned to the same "Hide Group" will turn green.
9. Click the "H" button at the top of the ARRANGE window so that it glows orange.
Lovely - now I can just see tracks I want to see.

AND HERE'S THE BEST BIT...

Once you've hidden those pesky AUX tracks you can still control them from the AlphaTrack.
Here's how...

1. Open the MIXER window (Make sure "All" is selected at the top of the Mixer window - not "Arrange")
2. Click to select the AUX Channel you wish to control.
That's it... the AlphaTrack can now control that channel, even though it's hidden in the ARRANGE window.

Of course, the caveat of this methodology is that you can't SELECT hidden tracks via the AlphaTrack.

If you want to use the AlphaTrack to SELECT these tracks, simply unhide them temporarily by clicking the "H" button at the top of the ARRANGE window.

Trust me... follow these steps. They are not complicated. Do it once and you'll realise how simple it is to set things up this way.

Please ask me if you need any clarification.

Cheers!

Dave.

CS:Hi Dave,

Thanks for the details. It's good to hear useful tips from the folks in the trenches. As developers, we don't always know them all as well as you guys do.

CS