Topic: alpha track and windows 7

I cant seem to get my alphatrack to work with sonar 8.5 32 bit with widowns 7 it also wont work with sonar 8 32 bit.
Ive tried the solution in the download for vista and xp but
I get an error code saying the flie cant be registered or wont start. any help would be greatly appreciated!

Re: alpha track and windows 7

Hi strat1376,

I've heard of a few people having Sonar8.5 issues and I don't have a copy yet but once I do I'll see if I can reproduce this.  One thing I'd have to ask you is that when you reinstalled the drivers did you make sure that the AlphaTrack was unplugged?  Also, try going into Sonar/options/midi devices and make sure that 'AlphaTrack' is selected for both midi in and midi out.  Then go into Sonar/options/control surfaces and try deleting the AlphaTrack device in the list and then try re-adding it (making sure to select 'AlphaTrack' in the midi input and midi output fields and see if that helps. 

Let me know if any of these helps at all.  Or if you found a solution I'd be curious to know what that is.


Re: alpha track and windows 7

I couldn't make the Alpha Track work with Pro Tools until I started Pro Tools as an administrator.  I also had exactly the same problem with a Command 8 surface.  Again it worked when I started Pro Tools as an administrator.

The reason I'm mentioning this is that I believe that there is an extra layer of protection built into Windows 7 that won't allow a program like Pro Tools (or in your case Sonar) to rewrite system data on the hard drive.  Starting your DAW software as an administrator bypasses this protection.

I'll bet you anything that if you start Sonar as an administrator, your Alpha Track will configure just fine.  After it is configured, you can start Sonar normally from that point on.

Please reply to this post if this fixes your problem and let us know if that works.  I see lots of posts on the Pro Tools forum about control surfaces not working in Windows 7.  I believe that this is a common situation in Windows 7 and not related to whether you are running Sonar, Pro Tools, an Alpha Track , or some other control surface.  I'm really curious as to whether my assessment of this is correct.

Re: alpha track and windows 7

Hi Strat1376,

I finally got a copy of Sonar 8.5 and everything seems to be working properly in Windows 7 except for some changes cakewalk has made to their instrument tracks.  Long story short, you used to be able to access EQ parameters from Instrument tracks, but now they're just recognized as 'midi tracks' and this doesn't let you control EQ with a controller.  Waiting for a response from Cakewalk on this issue.  But everything else works normally.

I'm guessing you have a 64-Bit Windows 7 machine and want to use Sonar 32-Bit.  The error message you've mentioned sounds like it's possible that when you were manually registering the plug-in (.dll file) you may have typed a character or two wrong in the command prompt.  I'd double check that and if you're still having issues I recommend sending a screenshot or two to (of the command prompt and any error messages) to