Topic: Alphatrack with Pro Tools and Logic

Hi,

I just got an alphatrack and looking forward to mixing my next project with some hands on control. I've tested it out with Logic and it works a treat! Really amazing implementation.

I often work with Pro Tools and would be nice to get some feedback from people using the Alphatrack with Pro Tools. The first snag I've come across is a reverb plugin I use almost exclusively which only seems to have its first four parameters available for control! Quite a shock especially as I've checked with other plugins and it's not the case everytime : other plugins have all their parameters available. Looking at the plugin window, I can see the four parameters have a light blue highlight. I'm guessing this is something to do with the HUI protocol rather the Alphatrack itself. Anyone have any ideas or any similar experiences with the Alphatrack with Pro Tools?

Also, is there a way to add sends and inserts to a channel in Pro Tools with the Alphatrack?

Regards,
Paulo

Last edited by powlow (2009-10-22 03:06:47)

Re: Alphatrack with Pro Tools and Logic

I've come across a problem in logic : although I can bank 1 at a time with the track buttons, there is an 8 track long highlight which doesn't let me get to the last tracks (I can only get to the eighth track from the end). Is there a way around this so I can bank all the way to the last track?

From what I can see, I am not able to access aux channels with the alphatrack. Anyone else seen this or know how to solve it?

Last edited by powlow (2009-10-24 17:53:27)

Re: Alphatrack with Pro Tools and Logic

I have discovered that the problem is not that they are aux channels but that they are not in the arrange window. Simply selecting write automation mode and then returning to off or read will add a channel to the arrange window and you can then bank into it with the alphatrack.

The problem with the "Control Surface Selection" being 8 channels wide was actually due to Controller Commands left over from another controller I was using before the alphatrack. I simply got rid of them and the alphatrack works perfectly.

Such a joy to be able to automate parameters hands on with such a compact device!

Last edited by powlow (2009-10-28 06:03:59)


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Re: Alphatrack with Pro Tools and Logic

powlow wrote:

The first snag I've come across is a reverb plugin I use almost exclusively which only seems to have its first four parameters available for control!

     This issue is confirmed on my system too.  It must be that with the 8.0.1 update of Pro Tools LE the Alphatrack needs some sort of update to catch up.  It's not HUI.  Automap works fine with HUI...it's the AT!  I'm now using Automap with the Novation controller...which thankfully covers my control needs but I would like to see FDG figure out these issues for Pro Tools users.  The AT has become an extension of my left hand...please don't take it away FDG...update the thing with a firmware or driver to support Digi!

Last edited by Gothboy (2009-11-08 10:21:14)

Re: Alphatrack with Pro Tools and Logic

Ok great to see someone else has this problem. I found it on another plugin too : only four parameters mapped...

Is there or should there be a way to assign plugins and sends from the alphatrack in pro tools?


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 684

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/frontierdesign/frontierdesign.com/forums/include/parser.php on line 738

Re: Alphatrack with Pro Tools and Logic

powlow wrote:

Is there or should there be a way to assign plugins and sends from the alphatrack in pro tools?

I've not tried to do this actually so I don't really know.  I don't think so but I'll have a look.

I just want FDG to fix the EQ on insert c issue and the now reduced paramater thing...support seems to be slipping with this controller.  Just a shame.

Re: Alphatrack with Pro Tools and Logic

So is the AT for Pro Tools even supported?  You know it's frustrating when each and every OTHER support issue post is answered...but not this one.  At this point I'm just assuming the answer is no.
*pfff*

The AT is now working at 75% for us RTAS users and we'd like some support.

Last edited by Gothboy (2009-11-09 18:09:50)

Re: Alphatrack with Pro Tools and Logic

Hi sorry for the delay in response,

I tried all the built in reverb plug-ins in ProTools and each parameter is accessible with the AlphaTrack.  If this is a third party reverb plug-in I'd be curious to know what it is so I can try to reproduce this.  Does the novation access these parameters on this reverb plug-in?  Are you able to page through the plug-in parameters or cycle through the parameters with the AlphaTrack knobs?

Also, I'm pretty sure you won't be able to assign plug-ins and sends from the AlphaTrack in ProTools.  I thought I remember doing this before but it was in Logic and not in ProTools.  And there's no fix yet for the EQ3 so you'll still need to access it through the AlphaTrack's plug-in mode.

CS

Re: Alphatrack with Pro Tools and Logic

Hi CS,

The reverb plugins are 3rd party. Oxford Reverb only has its first 3 parameters available and McDSP Revolver only has its first 4 available. Can anything be done to have more parameters available?

As far as assigning plug-ins and send from the AlphaTrack, it can be done in Logic and is a really nice touch. Would have been nice to have it in Pro Tools...

Re: Alphatrack with Pro Tools and Logic

Hi powlow,

I tried the Oxford Reverb plug-in and I experienced the same thing you did.  It's not unusual for this to happen to controllers in ProTools for 3P plug-ins as it may be a HUI limitation.  If other controllers using HUI protocol can access more than 3 or 4 parameters on this plug-in it would be good to know.  But I don't think there's much to do about it.

CS